View Issue Details

IDProjectCategoryView StatusLast Update
0003937Simple:Pressforum toolspublic2017-12-23 16:34
ReporterMr PapaAssigned To 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status newResolutionopen 
Product Version5.3.1 
Target VersionFuture ReleaseFixed in Version 
Summary0003937: Add trash feature for deleted things
Descriptionknow we had a ticket on this at some point, but couldnt find it... if discussed and I just forgot why closed, bring it back up....

but makes sense to have a second level of deletion for post, topics and maybe groups/forums... when deleting, they go into trash... and can be restored until the trash is emptied...

lots of good use cases for this...
TagsNo tags attached.
change_log_textupdate
typenew feature

Activities

Mr Papa

Mr Papa

2014-08-23 20:41

administrator   ~0014810

Last edited: 2014-08-23 20:42

View 2 revisions

will need discussion on best mechanism...

originally thought new table, but it potentially would need to hold everything in sftopics and sfposts... so might be better to add new status for each for trash state (could be new column too) and just not display if trashed...

Mr Papa

Mr Papa

2016-02-28 17:58

administrator   ~0017471

going to restate this... still think its a good idea... not sure why we abandoned it - no notes...
Mr Papa

Mr Papa

2016-08-14 19:17

administrator   ~0018320

Last edited: 2016-08-14 19:17

View 2 revisions

our slack discussion on this is gone... probably need to rekindle...

wonder if this could be a plugin? seems like it and could be a Group 1 plugin...

Mr Papa

Mr Papa

2016-08-14 19:56

administrator   ~0018321

biggest problem as plugin (easily solved) is we need more hooks... currently alot of our hooks fire after things have been deleted... we would likely need to add ones before deleting so the data could be grabbed...

cant remember, were we thinking new table(s) or new column in trashable tables (ie topics, posts, etc) to signify in trash? latter seems easier (?), but then have to deal with queries to ignore trashed items... former, likely means duplicate tables of trashable items...

also, probably need an admin panel for restoring items...
Mr Papa

Mr Papa

2016-08-14 20:08

administrator   ~0018322

what should be considered trashable? change over time? seems like initial list

groups
forums
topics
posts

some of those would of course save multiple items...

what about users? my initial would be no... that is wp territory and would require us to save and reinstated wp users... seems like slippery slope...

huge list of things we could trash to include attachments, PMs, avatars, etc... but seems like for initial release, we focus on the main ones listed above... we could consider PMs since they are pretty significant...

others I am missing?
Yellow Swordfish

Yellow Swordfish

2016-08-14 20:11

administrator   ~0018323

As much as I am all for data separation I would think new column in appropriate tables would be the best, simplest and easiest way to go - especially in terms of an undo operation...
Yellow Swordfish

Yellow Swordfish

2016-08-14 20:15

administrator   ~0018324

Agree on main four plus pm. Unsure about users. That could get real messy...
Yellow Swordfish

Yellow Swordfish

2016-08-20 19:34

administrator   ~0018353

I thought more on this and figured we should perhaps follow WP's lead. They allow for posts and pages to go to trash but not users. Sensible to me it seems.
svn

svn

2016-08-21 17:28

administrator   ~0018358

Changeset [14514] by steve on 2016-08-21 13:28:22 -0400 (Sun, 21 Aug 2016)

see issue 0003937 add filters to allow plugins to hook in pre post delete and override

 Changed Files:

U trunk/forum/database/sp-db-management.php
U trunk/sp-api/sp-api-cache.php
U trunk/sp-api/sp-api-wpdb.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=14514

Issue History

Date Modified Username Field Change
2013-09-08 05:55 Mr Papa New Issue
2013-10-01 19:52 Yellow Swordfish type defect => enhancement
2014-08-23 16:43 Mr Papa Target Version Future Release => 5.5.2
2014-08-23 16:45 Mr Papa Status new => assigned
2014-08-23 16:45 Mr Papa Assigned To => Mr Papa
2014-08-23 20:41 Mr Papa Note Added: 0014810
2014-08-23 20:42 Mr Papa Note Edited: 0014810 View Revisions
2014-09-28 06:26 Mr Papa Target Version 5.5.2 => 5.5.3
2014-10-28 04:03 Mr Papa Change Log Text => update
2014-10-28 04:03 Mr Papa Assigned To Mr Papa =>
2014-10-28 04:03 Mr Papa Status assigned => new
2014-11-15 16:03 Mr Papa Target Version 5.5.3 => Future Release
2015-02-03 14:22 Yellow Swordfish Category admin tools => forum tools
2015-04-24 02:35 Mr Papa Target Version Future Release =>
2015-04-24 02:35 Mr Papa Status new => closed
2016-02-28 17:57 Mr Papa type enhancement => new feature
2016-02-28 17:57 Mr Papa Status closed => assigned
2016-02-28 17:57 Mr Papa Target Version => 5.6.6
2016-02-28 17:58 Mr Papa Note Added: 0017471
2016-02-28 17:58 Mr Papa Status assigned => new
2016-05-06 19:05 Mr Papa Target Version 5.6.6 => 5.6.7
2016-05-20 21:48 Mr Papa Target Version 5.6.7 => 5.6.8
2016-07-12 00:21 Mr Papa Target Version 5.6.8 => 5.7
2016-07-16 14:48 Mr Papa Target Version 5.7 => 5.7.1
2016-08-14 19:17 Mr Papa Note Added: 0018320
2016-08-14 19:17 Mr Papa Note Edited: 0018320 View Revisions
2016-08-14 19:56 Mr Papa Note Added: 0018321
2016-08-14 20:08 Mr Papa Note Added: 0018322
2016-08-14 20:11 Yellow Swordfish Note Added: 0018323
2016-08-14 20:15 Yellow Swordfish Note Added: 0018324
2016-08-20 15:29 Mr Papa Target Version 5.7.1 => 5.7.2
2016-08-20 19:26 Mr Papa Assigned To => Mr Papa
2016-08-20 19:34 Yellow Swordfish Note Added: 0018353
2016-08-20 19:40 Mr Papa Status new => assigned
2016-08-21 17:28 svn =>
2016-08-21 17:28 svn Note Added: 0018358
2016-10-05 07:13 Yellow Swordfish Target Version 5.7.2 => 5.7.3
2016-10-22 06:53 Mr Papa Target Version 5.7.3 => Future Release
2017-12-23 16:34 Mr Papa Assigned To Mr Papa =>
2017-12-23 16:34 Mr Papa Status assigned => new