View Issue Details

IDProjectCategoryView StatusLast Update
0004906Hide Posters[Simple:Press] code - generalpublic2017-08-12 12:50
ReporterYellow SwordfishAssigned ToYellow Swordfish 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionnot a bug 
Product Version 
Target VersionFixed in Version 
Summary0004906: Repeated Notice in Log
Descriptionevery page load - sometimes getting multiples as well:

file: ndy/sites/simple-press/wp-content/sp-resources/forum-plugins/hide-poster/sp-hide-poster-plugin.php
line: 223
function: sp_hide_poster_group_forum_records
Notice | Undefined property: stdClass::$forum_hide_posters
TagsNo tags attached.
change_log_textadded a cache flush at the end of the plugin install
typedefect

Activities

Mr Papa

Mr Papa

2015-05-14 01:01

administrator   ~0015964

I am unable to replicate this... no errors... tried viewing as admin, user and guest... error logs clean...

but not sure hide posters working anymore either... so might be related... not sure why...
Mr Papa

Mr Papa

2015-05-14 01:40

administrator   ~0015965

scratch that... its working fine (forget its not totally automatic)...

but still cannot generate any notices/errors...

this is local, right?
svn

svn

2015-05-29 09:33

administrator   ~0016070

Changeset [12954] by andy on 2015-05-29 05:33:27 -0400 (Fri, 29 May 2015)

test issue 0004906
because a new column was being added to the forum table then I have added a cache flush at the end of the plugin install

 Changed Files:

U plugins/hide-poster/sp-hide-poster-install.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=12954
Mr Papa

Mr Papa

2015-05-29 13:03

administrator   ~0016071

so did this resolve the notice for you?
Yellow Swordfish

Yellow Swordfish

2015-05-29 13:06

administrator   ~0016072

Oh yes. The problem was that it did not immediately include the new column in the query/dataset because it would get that dataset from the cache. So by flushing it it makes sure it gets included.

Worth noting that this is the only current plugin that appears to need this
Yellow Swordfish

Yellow Swordfish

2017-08-12 12:50

administrator   ~0019572

Plugin needed to be uninstalled

Issue History

Date Modified Username Field Change
2015-05-13 09:45 Yellow Swordfish New Issue
2015-05-14 01:01 Mr Papa Note Added: 0015964
2015-05-14 01:40 Mr Papa Note Added: 0015965
2015-05-29 09:31 Yellow Swordfish Assigned To => Yellow Swordfish
2015-05-29 09:31 Yellow Swordfish Status new => assigned
2015-05-29 09:33 svn
2015-05-29 09:33 svn Note Added: 0016070
2015-05-29 09:33 svn Status assigned => testing
2015-05-29 13:03 Mr Papa Note Added: 0016071
2015-05-29 13:06 Yellow Swordfish Note Added: 0016072
2015-05-30 02:37 Mr Papa Change Log Text => added a cache flush at the end of the plugin install
2015-05-30 02:37 Mr Papa Status testing => closed
2015-05-30 02:37 Mr Papa Resolution open => fixed
2015-05-30 02:37 Mr Papa Fixed in Version => 5.5.7
2017-08-12 12:50 Yellow Swordfish Resolution fixed => not a bug
2017-08-12 12:50 Yellow Swordfish Product Version 5.5.6 =>
2017-08-12 12:50 Yellow Swordfish Fixed in Version 5.5.7 =>
2017-08-12 12:50 Yellow Swordfish Target Version 5.5.7 =>
2017-08-12 12:50 Yellow Swordfish Note Added: 0019572