View Issue Details

IDProjectCategoryView StatusLast Update
0005695Simple:Presscode - classespublic2017-07-11 01:58
ReporterMr PapaAssigned ToMr Papa 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.7.3 
Target Version5.8Fixed in Version5.8 
Summary0005695: do class files need the "cannot call directly" check
Descriptionsome of our class files have it, some do not... should be consistent.

my gut says they are not needed for class files, but we should answer and make all same...
TagsNo tags attached.
change_log_textremove special checks for class files being called directly since nothing but class in there
typeenhancement

Activities

Mr Papa

Mr Papa

2016-12-31 01:29

administrator   ~0018969

any thought on this one?

looked at bunch of other wp plugins (including EDD and RCP) and most do not... unless their is code outside the class, ie the instantiation...

not sure much could be done by calling a file with everything in class... my gut says we could get rid of...

thoughts?
Yellow Swordfish

Yellow Swordfish

2016-12-31 09:45

administrator   ~0018974

Sounds right to me. So sure - let's remove them
svn

svn

2017-01-02 23:03

administrator   ~0018991

Changeset [14983] by steve on 2017-01-02 18:03:22 -0500 (Mon, 02 Jan 2017)

test issue 0005695 lets not put special checks for class files being called directly since nothing but class in there

 Changed Files:

U trunk/sp-api/sp-api-class-spcactivity.php
U trunk/sp-api/sp-api-class-spcauths.php
U trunk/sp-api/sp-api-class-spccache.php
U trunk/sp-api/sp-api-class-spccompressor.php
U trunk/sp-api/sp-api-class-spcdatetime.php
U trunk/sp-api/sp-api-class-spcdisplayfilters.php
U trunk/sp-api/sp-api-class-spceditfilters.php
U trunk/sp-api/sp-api-class-spcerror.php
U trunk/sp-api/sp-api-class-spcfilters.php
U trunk/sp-api/sp-api-class-spcmemberdata.php
U trunk/sp-api/sp-api-class-spcmeta.php
U trunk/sp-api/sp-api-class-spcnotifications.php
U trunk/sp-api/sp-api-class-spcoptions.php
U trunk/sp-api/sp-api-class-spcpermalinks.php
U trunk/sp-api/sp-api-class-spcpost.php
U trunk/sp-api/sp-api-class-spcprimitives.php
U trunk/sp-api/sp-api-class-spcsavefilters.php
U trunk/sp-api/sp-api-class-spcuser.php
U trunk/sp-startup/admin/spa-admin-class-spcplugininstallerskin.php
U trunk/sp-startup/admin/spa-admin-class-spcpluginupgrader.php
U trunk/sp-startup/admin/spa-admin-class-spcpluginupgraderskin.php
U trunk/sp-startup/admin/spa-admin-class-spcthemeinstallerskin.php
U trunk/sp-startup/admin/spa-admin-class-spcthemeupgrader.php
U trunk/sp-startup/admin/spa-admin-class-spcthemeupgraderskin.php
U trunk/sp-startup/sp-load-class-spccoreloader.php
U trunk/sp-startup/sp-load-class-spcforumloader.php
U trunk/sp-startup/sp-load-class-spcsiteloader.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=14983

Issue History

Date Modified Username Field Change
2016-12-25 18:08 Mr Papa New Issue
2016-12-31 01:29 Mr Papa Note Added: 0018969
2016-12-31 09:45 Yellow Swordfish Note Added: 0018974
2017-01-02 22:44 Mr Papa Assigned To => Mr Papa
2017-01-02 22:44 Mr Papa Status new => assigned
2017-01-02 23:03 svn =>
2017-01-02 23:03 svn Note Added: 0018991
2017-01-02 23:03 svn Status assigned => testing
2017-01-07 20:31 Mr Papa Status testing => closed
2017-01-07 20:31 Mr Papa Resolution open => fixed
2017-01-07 20:31 Mr Papa Fixed in Version => 6.0
2017-01-07 20:31 Mr Papa change_log_text update => remove special checks for class files being called directly since nothing but class in there
2017-07-11 01:58 Mr Papa Fixed in Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Target Version 6.0 => 5.8