View Issue Details

IDProjectCategoryView StatusLast Update
0005702Simple:Pressdatabase and sqlpublic2017-07-11 01:58
ReporterYellow SwordfishAssigned ToYellow Swordfish 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.7.3 
Target Version5.8Fixed in Version5.8 
Summary0005702: Rearrange primary keys in the sfmeta table
DescriptionDemote meta_id from being the primary key
Create a dual key of meta_type and meta_key
This will help with updates
TagsNo tags attached.
change_log_textRearrange primary keys in the sfmeta table
typedefect

Activities

svn

svn

2016-12-29 12:20

administrator   ~0018937

Changeset [14941] by andy on 2016-12-29 07:20:21 -0500 (Thu, 29 Dec 2016)

see issue 0005702
Change primary keys in sfmeta and ensure no dupes in revised table

 Changed Files:

U trunk/sp-control.php
D trunk/sp-startup/install/resources/versions/update5-6.html
U trunk/sp-startup/install/sp-install.php
U trunk/sp-startup/install/sp-upgrade.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=14941

Issue History

Date Modified Username Field Change
2016-12-29 12:12 Yellow Swordfish New Issue
2016-12-29 12:12 Yellow Swordfish Assigned To => Yellow Swordfish
2016-12-29 12:20 svn =>
2016-12-29 12:20 svn Note Added: 0018937
2016-12-29 12:21 Yellow Swordfish Status new => testing
2017-01-01 17:54 Mr Papa Status testing => closed
2017-01-01 17:54 Mr Papa Resolution open => fixed
2017-01-01 17:54 Mr Papa Fixed in Version => 6.0
2017-03-20 00:38 Mr Papa Product Version 5.7.4 => 5.7.3
2017-07-11 01:58 Mr Papa Fixed in Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Target Version 6.0 => 5.8