View Issue Details

IDProjectCategoryView StatusLast Update
0005710Simple:Pressgeneralpublic2017-07-11 01:58
ReporterMr PapaAssigned ToMr Papa 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.7.3 
Target Version5.8Fixed in Version5.8 
Summary0005710: add api for adding storage location
Descriptioncode is common and spread around... lets add an api...
TagsNo tags attached.
change_log_textadd api for adding storage location
typeenhancement

Activities

svn

svn

2017-01-15 19:35

administrator   ~0019054

Changeset [15050] by steve on 2017-01-15 14:35:20 -0500 (Sun, 15 Jan 2017)

see issue 0005710 add api for plugins to add/remove storage locations

 Changed Files:

U trunk/sp-api/sp-api-class-spcplugin.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15050
svn

svn

2017-01-15 19:36

administrator   ~0019055

Changeset [15051] by steve on 2017-01-15 14:36:19 -0500 (Sun, 15 Jan 2017)

see issue 0005710 utilize new api for adding/removing storage locations - other plugins still need updating as this was just the test case plugin

 Changed Files:

U plugins/reputation/sp-reputation-install.php
U plugins/reputation/sp-reputation-uninstall.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15051
svn

svn

2017-01-15 21:22

administrator   ~0019063

Changeset [15059] by steve on 2017-01-15 16:22:30 -0500 (Sun, 15 Jan 2017)

test issue see issue 0005710 utilize new api for adding/removing storage locations

 Changed Files:

U plugins/gravatar-cache/sp-gravatar-cache-install.php
U plugins/gravatar-cache/sp-gravatar-cache-uninstall.php
U plugins/identities/sp-identities-install.php
U plugins/identities/sp-identities-uninstall.php
U plugins/plupload/sp-plupload-install.php
U plugins/plupload/sp-plupload-uninstall.php
U plugins/policy-doc/sp-policy-doc-install.php
U plugins/policy-doc/sp-policy-doc-uninstall.php
U plugins/reputation/sp-reputation-uninstall.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15059
Yellow Swordfish

Yellow Swordfish

2017-01-19 09:31

administrator   ~0019068

When activating the Gravatar Cache plugin I received this warning:
Warning wrote

mkdir(): File exists - file: /simple-press/sp-api/sp-api-class-spcplugin.php - line: 864 - function: mkdir

Not sure if this is just this particular plugin but it would seem worthwhile checking for the pre-existence of a storage location before attempting to create it
Mr Papa

Mr Papa

2017-01-20 05:04

administrator   ~0019069

guess it never did it before so carried it forward.. think its not very likely in normal usage for it to happen especially since the storage record wont exist... but that said, probably not hard to update to check..
svn

svn

2017-01-21 02:11

administrator   ~0019070

Changeset [15061] by steve on 2017-01-20 21:11:07 -0500 (Fri, 20 Jan 2017)

test issue 0005710 see if directory exists before trying to create

 Changed Files:

U trunk/sp-api/sp-api-class-spcplugin.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15061

Issue History

Date Modified Username Field Change
2017-01-09 04:38 Mr Papa New Issue
2017-01-15 17:48 Mr Papa Assigned To => Mr Papa
2017-01-15 17:48 Mr Papa Status new => assigned
2017-01-15 19:35 svn =>
2017-01-15 19:35 svn Note Added: 0019054
2017-01-15 19:36 svn =>
2017-01-15 19:36 svn Note Added: 0019055
2017-01-15 21:22 svn =>
2017-01-15 21:22 svn Note Added: 0019063
2017-01-15 21:23 Mr Papa Status assigned => testing
2017-01-19 09:31 Yellow Swordfish Status testing => rework
2017-01-19 09:31 Yellow Swordfish Note Added: 0019068
2017-01-20 05:04 Mr Papa Note Added: 0019069
2017-01-21 02:11 svn =>
2017-01-21 02:11 svn Note Added: 0019070
2017-01-21 02:11 svn Status rework => testing
2017-02-04 17:15 Mr Papa Status testing => closed
2017-02-04 17:15 Mr Papa Resolution open => fixed
2017-02-04 17:15 Mr Papa Fixed in Version => 6.0
2017-02-04 17:15 Mr Papa change_log_text update => add api for adding storage location
2017-07-11 01:58 Mr Papa Fixed in Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Target Version 6.0 => 5.8