View Issue Details

IDProjectCategoryView StatusLast Update
0005712Simple:Pressdisplay - generalpublic2017-07-11 01:58
ReporterMr PapaAssigned ToYellow Swordfish 
PrioritycriticalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.8 
Target Version5.8Fixed in Version5.8 
Summary0005712: subforums are broke
Descriptionthought I would take quick look at subforum permalinks tonight (get a feel how hard)... but subforums in general seem broken...

add a subforum, but its never shown on front end.... not on group view or forum view... tried many themes...

also tried on 5.7.4 to make sure not general issue, but worked there... so we broke something in the 6.0 changes..
TagsNo tags attached.
change_log_textCorrect table and array usage in auths class and allow empty data in SQL update method
typedefect

Activities

Yellow Swordfish

Yellow Swordfish

2017-01-10 10:19

administrator   ~0019024

Last edited: 2017-01-10 10:39

View 2 revisions

The problem lies in this call:
if (SP()->spAuths->can_view($forumid, 'forum-title'))

Even though I am logged in as an admin the call is returning a false when it should not.

The difficult question is why... I gave my subforum standard access permissions for Platinum and VIP users and Moderator access for moderators.

If I log in as a platinum user - I get to see the subforum. Logged in as Admin I do not. But curiously - I DO get to see all of the other forums which are subject to the same auths check.

Yellow Swordfish

Yellow Swordfish

2017-01-10 10:48

administrator   ~0019025

Looks like it is the resetting of th auths cache that is not working.
Does not work from the toolbox either. So the new subforum never gets added to the users auth cached record. Ands the user I logged in as didnlt have a cached record so it was created and, of course, therefore contained the new subforum
svn

svn

2017-01-10 12:34

administrator   ~0019026

Changeset [15020] by andy on 2017-01-10 07:34:38 -0500 (Tue, 10 Jan 2017)

test issue 0005712
Correct table and array usage in auths class and allow empty data in SQL update method.

 Changed Files:

U trunk/sp-api/sp-api-class-spcauths.php
U trunk/sp-api/sp-api-class-spcdb.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15020

Issue History

Date Modified Username Field Change
2017-01-09 05:09 Mr Papa New Issue
2017-01-10 10:19 Yellow Swordfish Note Added: 0019024
2017-01-10 10:39 Yellow Swordfish Note Edited: 0019024 View Revisions
2017-01-10 10:48 Yellow Swordfish Note Added: 0019025
2017-01-10 12:34 svn =>
2017-01-10 12:34 svn Note Added: 0019026
2017-01-10 12:34 svn Status new => testing
2017-01-10 22:07 Mr Papa Assigned To => Yellow Swordfish
2017-01-10 22:07 Mr Papa Status testing => assigned
2017-01-10 22:07 Mr Papa change_log_text => update
2017-01-10 22:08 Mr Papa Status assigned => testing
2017-01-11 02:45 Mr Papa Status testing => closed
2017-01-11 02:45 Mr Papa Resolution open => fixed
2017-01-11 02:45 Mr Papa Fixed in Version => 6.0
2017-01-11 02:45 Mr Papa change_log_text update => Correct table and array usage in auths class and allow empty data in SQL update method
2017-01-11 02:46 Mr Papa Product Version 5.7.3 => 6.0
2017-07-11 01:57 Mr Papa Product Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Fixed in Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Target Version 6.0 => 5.8