View Issue Details

IDProjectCategoryView StatusLast Update
0005743Simple:Presscode - template functionspublic2017-07-11 01:58
ReporterYellow SwordfishAssigned ToMr Papa 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version5.8 
Target Version5.8Fixed in Version5.8 
Summary0005743: Group View - The open/close of newpost list seems to have ceased working
DescriptionNoticeable on the sp-reboot theme - this refers to the control on the right hand side of each forum row that calls an ajax function to display any new posts available for that forum - only shown, of course, when there are new posts available.
TagsNo tags attached.
change_log_textclosing as duplicate
typedefect

Activities

Mr Papa

Mr Papa

2017-02-05 19:14

administrator   ~0019183

This is because of the work done under 0005707 or 0005741...

there used to a unique forum list ID applied to the div container of forums... now there is just a non unique class spGroupForumContainer... so the open/close js is trying to use the ID specific forum list...

can play around and see if we can use the first occurrence of the non unique class...
Mr Papa

Mr Papa

2017-02-05 19:20

administrator   ~0019184

No, that wont work... that class of that div is determined by the theme... so cannot assume...

so the sp_SectionStart had the forumlist argument removed which is what was keyed on before...
Yellow Swordfish

Yellow Swordfish

2017-02-06 18:23

administrator   ~0019189

I don't see this as the problem.
It looks like there is no data being returned - so this - in the spListView template:
if (SP()->spForum->view->has_list()) : while (SP()->spForum->view->loop_list()) 
: SP()->spForum->view->the_list();

is failing.

In fact - I am seeing a fatal error here:
error log wrote

Fatal error: Uncaught Error: Call to undefined method stdClass::has_list()


The actual container in the display seems to populate correctly if you examine it.
Yellow Swordfish

Yellow Swordfish

2017-02-07 11:33

administrator   ~0019194

Last edited: 2017-02-07 11:34

View 2 revisions

Actually - the new post popup doesn't work and errors as well - uses the same code of course.
Seem to have traced the start of the problem to file: sp-ajax-newpostpopup.php line 33.

Not sure why or what is going on here - all new code. But...
SP()->spForum->view

has no value at all. Doesn't seem right...

Mr Papa

Mr Papa

2017-02-10 23:58

administrator   ~0019199

certainly different behavior than i am seeing... I am not getting the error you see and the display on the container div was wrong...

suspect its a difference again of plugins vs no plugins... your unread post popup may provide the needed info... could be multiple instantiation like I was seeing with bootstrap...
Mr Papa

Mr Papa

2017-02-11 00:39

administrator   ~0019205

ticket 0005752 fixes the issue you see with the list view object not existing, but it doesnt do anything for this issue... its still there...

the forum id on the forum list container is still missing... so the jquery has nothing to act on...

5.7.4 container looks like

<div id="forumlist17" class="spGroupForumContainer">
6.0 container looks like:
<div class="spGroupForumContainer">


This is of course for member support group (group id = 17)... sure looks like the section start is no longer putting that unique ID in there...
Yellow Swordfish

Yellow Swordfish

2017-02-11 10:16

administrator   ~0019206

I think I have worked out why you are wrong here. As the ticket states - 'The open/close of newpost list'. That is nothing to do with what you are referring to which is the group/open/close control.

So - on the first - the new post listings - after changes you made last night this now works as expected.

On the open/close group control - this works on all themes except sp-reboot. I have not updated sp-reboot. I suppose largely because I do not use it locally at all.
Mr Papa

Mr Papa

2017-02-11 15:38

administrator   ~0019209

then this ticket just needs closing... no code changes with it...

Issue History

Date Modified Username Field Change
2017-01-31 13:59 Yellow Swordfish New Issue
2017-02-05 19:14 Mr Papa Note Added: 0019183
2017-02-05 19:20 Mr Papa Note Added: 0019184
2017-02-06 18:23 Yellow Swordfish change_log_text => Group View - The open/close of newpost list seems to have ceased working
2017-02-06 18:23 Yellow Swordfish Note Added: 0019189
2017-02-07 11:33 Yellow Swordfish Note Added: 0019194
2017-02-07 11:34 Yellow Swordfish Note Edited: 0019194 View Revisions
2017-02-10 23:58 Mr Papa Note Added: 0019199
2017-02-11 00:39 Mr Papa Note Added: 0019205
2017-02-11 10:16 Yellow Swordfish Note Added: 0019206
2017-02-11 10:18 Yellow Swordfish Assigned To => Mr Papa
2017-02-11 10:18 Yellow Swordfish Status new => testing
2017-02-11 15:38 Mr Papa Note Added: 0019209
2017-02-11 15:38 Mr Papa Status testing => closed
2017-02-11 15:38 Mr Papa Resolution open => duplicate
2017-02-11 15:38 Mr Papa change_log_text Group View - The open/close of newpost list seems to have ceased working => closing as duplicate
2017-04-03 08:26 Yellow Swordfish Fixed in Version => 6.0
2017-07-11 01:57 Mr Papa Product Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Fixed in Version 6.0 => 5.8
2017-07-11 01:58 Mr Papa Target Version 6.0 => 5.8