View Issue Details

IDProjectCategoryView StatusLast Update
0005834Simple:Presslocalizationpublic2017-08-05 23:38
ReporterMr PapaAssigned ToMr Papa 
PriorityhighSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.7.5 
Target Version5.8Fixed in Version5.8 
Summary0005834: user new post flag using wrong translation function
Descriptionbelieve the user new post flag stuff was coded with the wrong translation function... Its using __sp() which is only used in theme template files...

I believe it should be using sp_text() for core front end translation...

One could postulate the translation might be desired in the theme po file, but it wont get there (and is not) because poedit doesnt run on core files (or at least we didnt)... since this is the only place (well, one more I will get to at end) where we use __sp() in core, I think its wrong...

As mentioned, there is one more place where __sp() is used... its in the sp_SearchForm() default args... probably should be sp_text() as well, like other default arguments...
TagsNo tags attached.
change_log_textfix couple translations using wrong translation function
typedefect

Activities

svn

svn

2017-07-31 06:40

administrator   ~0019546

Changeset [15480] by steve on 2017-07-31 02:40:19 -0400 (Mon, 31 Jul 2017)

test issue 0005834 fix couple translations using wrong translation function

 Changed Files:

U trunk/forum/content/sp-common-view-functions.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15480

Issue History

Date Modified Username Field Change
2017-07-29 17:01 Mr Papa New Issue
2017-07-31 06:35 Mr Papa Assigned To => Mr Papa
2017-07-31 06:35 Mr Papa Status new => assigned
2017-07-31 06:35 Mr Papa change_log_text => update
2017-07-31 06:40 svn =>
2017-07-31 06:40 svn Note Added: 0019546
2017-07-31 06:40 svn Status assigned => testing
2017-08-05 23:38 Mr Papa Status testing => closed
2017-08-05 23:38 Mr Papa Resolution open => fixed
2017-08-05 23:38 Mr Papa Fixed in Version => 5.8
2017-08-05 23:38 Mr Papa change_log_text update => fix couple translations using wrong translation function