View Issue Details

IDProjectCategoryView StatusLast Update
0005846Simple:Presscode - template functionspublic2017-09-29 03:49
ReporterYellow SwordfishAssigned ToYellow Swordfish 
PriorityhighSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.7.5.1 
Target Version5.8Fixed in Version5.8 
Summary0005846: Add standard class to both Quick Links dropdown
DescriptionAdd class of 'spQuickLinks'
TagsNo tags attached.
change_log_textAdd standard class to both Quick Links dropdown
typeenhancement

Activities

svn

svn

2017-08-23 12:25

administrator   ~0019591

Changeset [15520] by andy on 2017-08-23 08:25:56 -0400 (Wed, 23 Aug 2017)

see issue 0005846
Add new quick links class

 Changed Files:

U trunk/forum/content/sp-common-view-functions.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15520
Mr Papa

Mr Papa

2017-09-10 01:00

administrator   ~0019631

going to reopen... working, but just noticed that the cursor when hovering over links in the quick links does not change to a pointer... it should, like before...
svn

svn

2017-09-11 06:57

administrator   ~0019634

Changeset [15550] by andy on 2017-09-11 02:57:18 -0400 (Mon, 11 Sep 2017)

test issue 0005846
correctly tyle cursor

 Changed Files:

U templates/barebones/styles/barebones.php
U templates/barebones-legacy-changes.txt
U templates/default/styles/default.php
U templates/default-legacy-changes.txt
U templates/reboot/styles/reboot.php
U templates/reboot-legacy-changes.txt
U templates/stacked/styles/stacked.php
U templates/stacked-legacy-changes.txt
U templates/unified/styles/unified.php
U templates/unified-legacy-changes.txt

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15550
Mr Papa

Mr Papa

2017-09-23 00:52

administrator   ~0019645

we seem to have lost the blue/red coloring of text in the quicklinks... find I am missing it a lot... cant remember if its accidental or side effect of new dropdown...
Mr Papa

Mr Papa

2017-09-23 01:05

administrator   ~0019646

looks like side effect... but want it back... and there is now a bunch of dead code in the populate quicklinks common view functions...

if for some reason we cannot get the much valued colors back, we should at least clean up the code that is still trying to add them in sp_PopulateQuickLinksTopic() and maybe elsewhere (mobile?) too...
svn

svn

2017-09-23 18:18

administrator   ~0019648

Changeset [15558] by steve on 2017-09-23 14:18:22 -0400 (Sat, 23 Sep 2017)

test issue 0005846 restore quicklinks text coloring for unread and moderated topics

 Changed Files:

U trunk/forum/resources/jscript/msdropdown/msdropdown-dev.js
U trunk/forum/resources/jscript/msdropdown/msdropdown.js

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15558
svn

svn

2017-09-23 18:18

administrator   ~0019649

Changeset [15559] by steve on 2017-09-23 14:18:39 -0400 (Sat, 23 Sep 2017)

test issue 0005846 restore quicklinks text coloring for unread and moderated topics

 Changed Files:

U templates/barebones/styles/barebones.php
U templates/barebones-css-desktop/styles/barebones-desktop.css
U templates/barebones-css-mobile/styles/barebones-mobile.css
U templates/css-only/styles/css-only.css
U templates/default/styles/default.php
U templates/reboot/styles/reboot.php
U templates/stacked/styles/stacked.php
U templates/unified/styles/unified.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15559
Mr Papa

Mr Papa

2017-09-23 18:23

administrator   ~0019650

css only quicklinks not working with the new msdropdwon js... needs same attention given to other themes...

Issue History

Date Modified Username Field Change
2017-08-23 12:23 Yellow Swordfish New Issue
2017-08-23 12:24 Yellow Swordfish Assigned To => Yellow Swordfish
2017-08-23 12:24 Yellow Swordfish Status new => assigned
2017-08-23 12:25 svn =>
2017-08-23 12:25 svn Note Added: 0019591
2017-08-23 12:26 Yellow Swordfish Status assigned => testing
2017-09-03 21:44 Mr Papa Status testing => closed
2017-09-03 21:44 Mr Papa Resolution open => fixed
2017-09-03 21:44 Mr Papa Fixed in Version => 5.8
2017-09-10 01:00 Mr Papa Status closed => reopened
2017-09-10 01:00 Mr Papa Resolution fixed => reopened
2017-09-10 01:00 Mr Papa Note Added: 0019631
2017-09-11 06:57 svn =>
2017-09-11 06:57 svn Note Added: 0019634
2017-09-11 06:57 svn Status reopened => testing
2017-09-11 06:57 svn Resolution reopened => open
2017-09-15 07:13 Mr Papa Status testing => closed
2017-09-15 07:13 Mr Papa Resolution open => fixed
2017-09-23 00:52 Mr Papa Status closed => reopened
2017-09-23 00:52 Mr Papa Resolution fixed => reopened
2017-09-23 00:52 Mr Papa Note Added: 0019645
2017-09-23 01:05 Mr Papa Note Added: 0019646
2017-09-23 18:18 svn =>
2017-09-23 18:18 svn Note Added: 0019648
2017-09-23 18:18 svn Status reopened => testing
2017-09-23 18:18 svn Resolution reopened => open
2017-09-23 18:18 svn =>
2017-09-23 18:18 svn Note Added: 0019649
2017-09-23 18:23 Mr Papa Status testing => rework
2017-09-23 18:23 Mr Papa Note Added: 0019650
2017-09-26 01:12 Mr Papa Status rework => testing
2017-09-29 03:49 Mr Papa Status testing => closed
2017-09-29 03:49 Mr Papa Resolution open => fixed