View Issue Details

IDProjectCategoryView StatusLast Update
0005875Syntax Highlighting[Simple:Press] code - generalpublic2017-12-31 12:01
ReporterYellow SwordfishAssigned ToMr Papa 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version[Simple:Press] 5.7.5.2 
Target Version[Simple:Press] 5.8Fixed in Version[Simple:Press] 5.8 
Summary0005875: Report says this no longer is working
DescriptionMight this be tied in with the tinymce console error?
TagsNo tags attached.
change_log_textCorrect failure in highlighting when there is an empty line in code block
typedefect

Activities

Yellow Swordfish

Yellow Swordfish

2017-12-04 09:18

administrator   ~0019705

Initial test seem to work just fine and as expected.
Mr Papa

Mr Papa

2017-12-10 18:24

administrator   ~0019710

still not working for me at all... any browser, live or local... from any editor... just weird... might still be down to just me, but....
Mr Papa

Mr Papa

2017-12-16 18:24

administrator   ~0019714

can you please retry with a more "complicated" code segment... namely one that has a blank line in it...
Yellow Swordfish

Yellow Swordfish

2017-12-17 11:27

administrator   ~0019715

You are correct. An empty line destroys it.
Curiously if you add code with no empty lines - save it -then go to edit the post and enter an empty line - it works correctly (because it has the right div class) but it removes the empty line.
Odd... could be a difficult one to solve...
Mr Papa

Mr Papa

2017-12-17 15:20

administrator   ~0019716

to me, last I looked, it seemed like html formatting was causing the issue... wonder if we have a wrong filter attached? we should try with 5.7 and see if same...
Yellow Swordfish

Yellow Swordfish

2017-12-17 15:37

administrator   ~0019717

Good thinking. It DOES seem OK in 5.7.6
Mr Papa

Mr Papa

2017-12-17 17:29

administrator   ~0019718

I meant to add I had also tested min scripts and dev scripts... and the cache... same result...

will go through the plugin and see if I can see a change accidentally made...
Mr Papa

Mr Papa

2017-12-17 17:43

administrator   ~0019719

our version seems out of date... wonder if a quick test with newer version makes any diff...
Mr Papa

Mr Papa

2017-12-17 18:12

administrator   ~0019720

seems to be same effect...
svn

svn

2017-12-30 22:20

administrator   ~0019755

Changeset [15608] by steve on 2017-12-30 17:20:17 -0500 (Sat, 30 Dec 2017)

test issue 0005875 handle wp tinymce changes for extra p tags when highlighting code

 Changed Files:

U plugins/syntax-highlighting/resources/jscript/syntax/syntax_plugin.js

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15608
Yellow Swordfish

Yellow Swordfish

2017-12-31 12:01

administrator   ~0019757

This is working perfectly now for me

Issue History

Date Modified Username Field Change
2017-12-02 21:48 Yellow Swordfish New Issue
2017-12-04 09:18 Yellow Swordfish Note Added: 0019705
2017-12-10 18:24 Mr Papa Note Added: 0019710
2017-12-16 18:24 Mr Papa Note Added: 0019714
2017-12-17 11:27 Yellow Swordfish Note Added: 0019715
2017-12-17 15:20 Mr Papa Note Added: 0019716
2017-12-17 15:37 Yellow Swordfish Note Added: 0019717
2017-12-17 17:29 Mr Papa Note Added: 0019718
2017-12-17 17:43 Mr Papa Note Added: 0019719
2017-12-17 18:12 Mr Papa Note Added: 0019720
2017-12-30 22:18 Mr Papa Assigned To => Mr Papa
2017-12-30 22:18 Mr Papa Status new => assigned
2017-12-30 22:20 svn =>
2017-12-30 22:20 svn Note Added: 0019755
2017-12-30 22:20 svn Status assigned => testing
2017-12-31 12:01 Yellow Swordfish Status testing => closed
2017-12-31 12:01 Yellow Swordfish Resolution open => fixed
2017-12-31 12:01 Yellow Swordfish Fixed in Version => 5.8
2017-12-31 12:01 Yellow Swordfish change_log_text Report says this no longer is working => Correct failure in highlighting when there is an empty line in code block
2017-12-31 12:01 Yellow Swordfish Note Added: 0019757