View Issue Details

IDProjectCategoryView StatusLast Update
0005878Admin Bar[Simple:Press] ajaxpublic2018-01-01 16:59
ReporterYellow SwordfishAssigned ToMr Papa 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version[Simple:Press] 5.8 
Target Version[Simple:Press] 5.8Fixed in Version[Simple:Press] 5.8 
Summary0005878: Admn Bar Quick Reply not saving
DescriptionThis may be a little inconsistent but I have had several failures using the quick reply feature. It is possibly when it is the first post in the list but I may be wrong about that. Just doesn't save.
TagsNo tags attached.
change_log_textuse class instead of id for quick reply form submit event since there are multiple forms when more than one item in postbag
typedefect

Activities

Mr Papa

Mr Papa

2017-12-22 00:38

administrator   ~0019725

unable to replicate this in couple quick tests... working fine for me...

may need more info on how to replicate... tried new topics and new posts... with one and two posts waiting in topic...

but only Chrome...
Mr Papa

Mr Papa

2017-12-23 22:13

administrator   ~0019727

any chance similar to: http://mantis.simple-press.com/view.php?id=5864

I have not been able to replicate...
Yellow Swordfish

Yellow Swordfish

2017-12-23 23:29

administrator   ~0019728

I had forgotten that ticket. So maybe the same of course. It has happened to me on the live site maybe 4-5 times over the last couple of weeks. And it appears random although I believe when there have been more than one post waiting it has been the first one that has failed. But as I said - I could be mistaken here.
The problem, of course, on the public site once confidence is lost in the tool one just stops using it. Tired of repeating all the typing of a reply already written. I shall use it and note results.
The site has not been misbehaving or slow by the way.
Mr Papa

Mr Papa

2017-12-23 23:46

administrator   ~0019729

I will continue playing and stuff the postbag more too...
Mr Papa

Mr Papa

2017-12-24 21:43

administrator   ~0019730

okay, I can recreate this now... and have a handle on what is going on... but not sure how it ever worked since the event handler days multiple versions ago in 5.7 land...
svn

svn

2017-12-24 21:49

administrator   ~0019731

Changeset [15598] by steve on 2017-12-24 16:49:48 -0500 (Sun, 24 Dec 2017)

test issue 0005878 use class instead of id for quick reply form submit event since there are multiple forms when more than one item in postbag

 Changed Files:

U plugins/admin-bar/library/sp-admin-bar-components.php
U plugins/admin-bar/resources/jscript/sp-admin-bar-dev.js
U plugins/admin-bar/resources/jscript/sp-admin-bar.js

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15598
Yellow Swordfish

Yellow Swordfish

2017-12-27 20:00

administrator   ~0019741

On my first test in the live site it certainly saved OK.
But I seem to remember that there were messages that the post was being saved and I saw none of those.
Do I recall this correctly?
Mr Papa

Mr Papa

2017-12-27 22:43

administrator   ~0019742

afraid I dont recall... generally, havent used the admin bar in some number of years... but can try to take a look...
Mr Papa

Mr Papa

2017-12-27 23:41

administrator   ~0019743

well, it actually is writing out a message... quite cryptic and ugly... in the header of the admin bar, there is a hidden area... when saving (or moderating), it writes a message out there...

its very hard to see - have to have the window scrolled right...

but its not using the standard messaging system... but it could, I think... but will need a bit of work to rewrite some jquery load calls to ajax, I believe... will have a play...
svn

svn

2017-12-28 00:34

administrator   ~0019744

Changeset [15599] by steve on 2017-12-27 19:34:48 -0500 (Wed, 27 Dec 2017)

test issue 0005878 use standard notifications for admin bar action messages

 Changed Files:

U plugins/admin-bar/ajax/sp-admin-bar-ajax-quickreply.php
U plugins/admin-bar/resources/jscript/sp-admin-bar-dev.js
U plugins/admin-bar/resources/jscript/sp-admin-bar.js

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15599

Issue History

Date Modified Username Field Change
2017-12-21 16:36 Yellow Swordfish New Issue
2017-12-22 00:38 Mr Papa Note Added: 0019725
2017-12-23 22:13 Mr Papa Note Added: 0019727
2017-12-23 23:29 Yellow Swordfish Note Added: 0019728
2017-12-23 23:46 Mr Papa Note Added: 0019729
2017-12-24 21:35 Mr Papa change_log_text => update
2017-12-24 21:43 Mr Papa Assigned To => Mr Papa
2017-12-24 21:43 Mr Papa Status new => assigned
2017-12-24 21:43 Mr Papa Note Added: 0019730
2017-12-24 21:49 svn =>
2017-12-24 21:49 svn Note Added: 0019731
2017-12-24 21:49 svn Status assigned => testing
2017-12-27 20:00 Yellow Swordfish Note Added: 0019741
2017-12-27 22:43 Mr Papa Note Added: 0019742
2017-12-27 23:41 Mr Papa Note Added: 0019743
2017-12-28 00:34 svn =>
2017-12-28 00:34 svn Note Added: 0019744
2018-01-01 16:59 Mr Papa Status testing => closed
2018-01-01 16:59 Mr Papa Resolution open => fixed
2018-01-01 16:59 Mr Papa Fixed in Version => 5.8
2018-01-01 16:59 Mr Papa change_log_text update => use class instead of id for quick reply form submit event since there are multiple forms when more than one item in postbag