View Issue Details

IDProjectCategoryView StatusLast Update
0005888Simple:Presscode - generalpublic2018-01-02 09:25
ReporterMr PapaAssigned ToMr Papa 
PrioritynormalSeverityN/AReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.8 
Target Version5.8Fixed in Version5.8 
Summary0005888: meta api when getting single value needs to support no meta found
Descriptionif the meta doesnt exist, need to return empty string vs trying to get from array
TagsNo tags attached.
change_log_textmeta api when getting single value needs to support no meta found
typedefect

Activities

svn

svn

2018-01-01 22:12

administrator   ~0019779

Changeset [15631] by steve on 2018-01-01 17:12:13 -0500 (Mon, 01 Jan 2018)

test issue 0005888 for meta->get_value() return empty string if meta doesnt exist

 Changed Files:

U trunk/sp-api/sp-api-class-spcmeta.php

 Differences:

 http://websvn.simple-press.com/revision.php?repname=Simple:Press&path=%2F&rev=15631
Yellow Swordfish

Yellow Swordfish

2018-01-02 09:25

administrator   ~0019781

Looks like it's covered and good.

Issue History

Date Modified Username Field Change
2018-01-01 22:09 Mr Papa New Issue
2018-01-01 22:09 Mr Papa Assigned To => Mr Papa
2018-01-01 22:09 Mr Papa Status new => assigned
2018-01-01 22:12 svn =>
2018-01-01 22:12 svn Note Added: 0019779
2018-01-01 22:12 svn Status assigned => testing
2018-01-02 09:25 Yellow Swordfish Status testing => closed
2018-01-02 09:25 Yellow Swordfish Resolution open => fixed
2018-01-02 09:25 Yellow Swordfish Fixed in Version => 5.8
2018-01-02 09:25 Yellow Swordfish change_log_text update => meta api when getting single value needs to support no meta found
2018-01-02 09:25 Yellow Swordfish Note Added: 0019781